Page 1 of 1

Video files,post deletions

Posted: Tue Jul 04, 2017 11:53 pm
by MK14HAK
Dave, does your new forum storage host allow us to upload video that we may reference from the forum?
Have we lost privileges to delete own posts ?

Re: Video files,post deletions

Posted: Wed Jul 05, 2017 12:24 pm
by dave
I've set up an Amazon "virtual" cloud instance from scratch, so I can completely control the environment. All the issues we are experiencing are more from my lack of expertise with the poorly documented and convoluted phpBB setup process.

It should be possible to upload video, but I may have to raise the upload limits. This machine only has 8 GB of storage total, including system software and uploads, and I've dedicated 2 GB to uploads. If we get a lot of video, then I may have to move to a larger host instance (which, now that we're on Amazon, would not require re-installing the forum, just a change to the control panel and reboot), or figure out some other way to attach storage. Of course, including links to video should not be an issue.

Also, I've set permissions (as much as I can tell) to allow deletion of own posts, but there seems to be some issues with setting permissions in phpBB3, and I may have overlooked an option. In general the documentation is not very clear, and troubleshooting involves looking through support forums at all the other instances of permissions gone wrong. I will try to clear this up, and post the progress in this thread.

Re: Video files,post deletions

Posted: Wed Jul 05, 2017 1:39 pm
by dave2
test

Re: Video files,post deletions

Posted: Wed Jul 05, 2017 3:37 pm
by Andis
Hi Dave,

Are you still receiving emails at dave@osiweb.org? I cannot PM anymore, no permissions. I sent an email yesterday, but my email client says, "will keep retrying for 2 days". I will send again via another email account i have.

Thx

Re: Video files,post deletions

Posted: Wed Jul 05, 2017 4:07 pm
by dave
Hi Andis,

I just tested and the emails are not making it through either. You can post here, or mail me at dfnum2@gmail.com in the meanwhile.

This whole forum issue has been quite a headache. I would have kept it a Midphase, if they didn't keep changing the environment and breaking the forum software.

The email issue should be straightforward to fix, as it's almost certainly a DNS misconfiguration issue. Amazon and Google are pretty solid, so I'm sure I have missed something.

Registered users should have permission to send PMs, but it seems there's something amiss with the phpBB permissions subsystem. I did receive the two PMs you sent me earlier. I haven't removed any capabilities (to my knowledge.) Can you try to post another?

Thanks for being patient with me on this.

Regards,

Dave