Finally working machines!

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Finally working machines!

Post by Steve Gray » Tue Feb 19, 2019 3:50 pm

Hi,

Well after 12+ years I finally have not one, but two (!!!) working machines! I recently learned my friend Walter wanted a superboard and I had one but not working. I traded him my superboard for a couple other vintage machines I was looking for. I knew Walter would be able to fix it and he did. So we looked at my C1P and my C4P (well, one of them). Both machines had power supply issues.

We tested my board superboard with Walter's (my old) superboard power supply (now fixed). My board worked but the memory size was low. We replaced one 2114 and now it's got the full 8K ram. My C1P supply needs a new voltage regulator. My friend Josh is going to fix that for me and I'll be good to go.

The C4 had one of it's two supplies giving low voltage (the one supplying the top two slots). The machine powered on but would not reset. Luckily the other supply was ok (it powered the bottom two slots). The CPU board was in the top slot, so after moving it to a bottom slot the machine now boots! The 502 board was configured for floppy drive but I didn't have the card so I decided to re-configure it for cassette. Unfortunately the machine was previously repaired and the monitor rom only contained the floppy code. I burned the standard SYNMON onto a 2716 and now the C4 is booting!!!!
DSC08430sm.jpg
DSC08430sm.jpg (281.29 KiB) Viewed 2231 times
It's like its 1981 again ;-)
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Re: Finally working machines!

Post by Steve Gray » Tue Feb 19, 2019 4:18 pm

I rarely had my C4P connected to a colour monitor, because it was a little TI-99 10" monitor and the 64 column mode was barely readable. Generally I used a 12" amber monitor for day-to-day use. I was eager to try colour, so I typed in a little program. It's neat to see after all these years. The LCD monitor does an ok job but I think I'm gonna try connecting it up via RGB - this LCD tv/monitor has SCART so it should handle it.
DSC08433-P50.jpg
DSC08433-P50.jpg (373.6 KiB) Viewed 2229 times
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

dave
Site Admin
Posts: 561
Joined: Tue Sep 09, 2008 5:24 am

Re: Finally working machines!

Post by dave » Thu Feb 21, 2019 11:01 pm

So glad to see you got them going!

MK14HAK
Posts: 351
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: Finally working machines!

Post by MK14HAK » Fri Feb 22, 2019 12:38 am

Well done Steve. Cassettes ? Maybe work with Phil to get those D&N controllers working. viewtopic.php?f=3&t=441
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Re: Finally working machines!

Post by Steve Gray » Fri Feb 22, 2019 3:54 am

I tried one other 502 cpu board but it did not work. Until I get a replacement power supply to get the other slots operational I won't be able to do much. I have another 540B video card I could test. I also have a 505 board but with only two slots I won't have any memory. I may try BillO's 32K ram board I bought in 2015 hoping I'd be able to use some day... I'll keep everyone posted.
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

MK14HAK
Posts: 351
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: Finally working machines!

Post by MK14HAK » Sat Feb 23, 2019 2:57 am

I have two of Bill's ram boards, one on RevD and the Ram/Rom on SKIT502. Quick to build and work fine.
630 Colour 600RevD.jpg
630 Colour 600RevD.jpg (80.14 KiB) Viewed 2186 times

Kicad me please. RevD in colour. :mrgreen:
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Re: Finally working machines!

Post by Steve Gray » Sat Feb 23, 2019 3:15 am

I wish i had a Rev D. If thats all it takes to get color from a rev d board (i assume you need to add one or more chips on the 600D board) then a little pcb wouldnt be too hard to make...
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

MK14HAK
Posts: 351
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: Finally working machines!

Post by MK14HAK » Sat Feb 23, 2019 3:22 am

Nothing more needed. J3 plugs to existing 16pin skt with supplied VID and COLOR signals. Any takers ?
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

Steve Gray
Posts: 283
Joined: Mon Oct 06, 2008 1:54 pm
Location: Markham, Ontario, Canada
Contact:

Re: Finally working machines!

Post by Steve Gray » Sun Feb 24, 2019 11:01 pm

Just for completeness, here is my C1P working!
C1P-working.jpg
C1P-working.jpg (298.79 KiB) Viewed 2165 times
C4P working, C1P working. 600D Replica working, C4P+D&N floppy not working. 505 board, 610 board, Mittendorf board, TOSIE hacker board need testing, PicoDOS disk untested.

MK14HAK
Posts: 351
Joined: Wed Mar 16, 2011 1:49 am
Location: New Zealand

Re: Finally working machines!

Post by MK14HAK » Mon Feb 25, 2019 7:31 am

Great your on a roll. Cegmon ? Floppies ?
600RevB:16K,2MHz,64x32,470,CEGMON
SuperKit:502,540B,542B,CEGMON, 8" and 5" FDDs
Cards:PE IO,6522 D-A-D, AY3-8910,ProgramGraphics,Color,UK101
WIP:HexDOS,FDD Emulator

Post Reply